blog.fohrn.com

Ab Montag (3.1.2011) bei Netto: Das Q-Book Mini-Netbook

Der Discount-Supermarkt Netto verkauft ab kommenden Montag, den 3. Januar 2011 wieder ein Netbook – diesmal unter der Bezeichnung Q-Book Mini-Netbook zum Preis von 89,98 Euro.

Zu den Spezifikationen schweigt sich der Prospekt, der heute viele Haushalte erreicht haben dürfte, quasi aus – hingewiesen wird lediglich darauf, dass das Gerät über Stereo-Lautsprecher, einen internen Speicher von 2 GB 3 USB-2.0-Anschlüsse, einen SD-Cardreader und W-LAN verfügen soll – laut Beschreibung eigne sich das Q-Book „ideal zum Surfen im Internet, E-Mail abrufen, Musik hören und Videos schauen“.

Eine erste Webrecherche zum vermeintlichen Hersteller „Q-Book“ lieferte auf den ersten Blick keine Treffer, allerdings wird man mit dem Suchbegriff „q-book“ auf etliche 7″-Netbooks stoßen, die unter Windows CE laufen und sich von Spezifikationen deutlich an das Jay-Book 9901 annähern, das Mitte dieses Jahres ebenfalls bei Netto zu einem Preis von 99 Euro angeboten wurde.

Beim Betrachten der Produktabbildung fallen frappierende Ähnlichkeiten zu besagtem Jay-Book 9901 auf: Sowohl die Anordnung der Tasten (und besonders der Sondertasten) entsprechen der des 9901, das selbe gilt für die Anordnung der LEDs auf der Frontseite. Auch das 9901 verfügt über ein 7-Zoll-Display, drei USB-Ports (hier sind aber zwei als USB 1.1. und nur einer als USB 2.0 ausgeführt), einen Cardreader, Stereo-Lautsprecher und W-LAN.

Zwar ist es noch Spekulation, allerdings gibt es deutliche Indizien dafür, dass es sich auch beim Q-Book um ein technisch mindestens ähnliches (wenn nicht gar baugleiches) Gerät zum 9901 handelt.

Bei diesem sind die wesentlichen Merkmale, dass das 9901 mit Win CE ausgeliefert wird, was bedeutet, dass eine Installation von Programmen, die unter XP, Vista oder 7 laufen, nicht möglich ist. Weiterhin werkelt im Gerät ein 300 MHz langsamer ARM-Prozessor, als wirklichen „Flaschenhals“ mache ich aber den 128 MB schmalen Hauptspeicher aus.

Kaufen oder nicht kaufen?

Sollte es sich beim Q-Book um ein dem 9901 ähnliches oder gar baugleiches Netbook handeln, was zwar Spekulation – aber trotzdem wahrscheinlich ist, hinterlässt das Gerät – selbst dann, wenn es das ein oder andere Update erfahren hat – einen ambivalenten Eindruck:

Computer-Einsteigern traue ich mich nicht, dieses Gerät reinen Herzens zu empfehlen, wer ein günstiges Netbook will und bereit ist zu experimentieren (und gegebenenfalls Software manuell zu modifizieren oder gar zu programmieren), der kann hier eventuell ein gutes Schnäppchen machen.

Wer sich den Kauf eines solch günstigen Geräts ernsthaft überlegt, den lade ich ein, dieses Post vom 20. Juni 2010 zu lesen und sich auch die Zeit für die Lektüre der zahlreichen und kompetenten Kommentare zu nehmen. Hier sind die Möglichkeiten und Limitationen solcher Geräte am Beispiel des 9901 sehr ausführlich dargestellt.

Ich kann natürlich nicht mit letztendlicher Sicherheit sagen, dass das Q-Book dem 9901 entspricht – es würde mich aber sehr wundern, wenn dem nicht so wäre.

Bitte merkt Euch in etwa die Spezifikationen des 9901, wenn Ihr Euch das Q-Book bei Netto zeigen lasst und vergleicht. Sollte das Q-Book mit Windows CE 6 betrieben werden und ein Office der Fa. SoftMaker nicht installiert sein/beiligen, wäre das in meinen Augen ein großes Manko.

Ich will versuchen, mir das Netbook am Montag bei Netto anzusehen. Versprechen kann ich das aber nicht. Sollte es klappen, berichte ich.

149 Kommentare

  • kettwiesel

    Da schau her ! nach dem ich jetzt ein Netzteil dranhängen habe, was auch Strom bringt, ist die Virtuelle Batterieanzeige auch plötzlich funktionstüchtig, vorher war kein eindeutiger Ladestatus erkennbar !

    und jetzt kommt der Witz !

    Herstellerangabe 9V 1500mA

    0,3 A

    Mein Netzteil….

    9V 500 mA 7VA

    Und ist ein Stabilisiertes Netzteil (Brumfrei) was eigentlich nur für meine E-Gitarren Effekt gerät gedacht war???

  • admin

    @kettwiesel zu Deinem Kommentar #94:

    Damals hatten wir eine Freeware-Sammlung für CE6. Ein Gutteil des Zeugs ließ sich entpackt auf die SD-Karte legen und funktionierte auf dem 9901. Mathias hat den Link gepostet.
    Das kanst Du Dir hier ansehen: http://www.filedropper.com/wince6freeware
    Bin mal gespannt, ob da was Brauchbares für Dich dabei ist und ob es auch auf dem Q-Book funzt…

  • cdc

    @thomas
    hab noch eins von heute früh rumkieseln, bevor die kiste zerlegt wurde und am internen ssd gefummelt wurde (zwecks backup dumping)

    http://picfront.de/d/806F

    – nicht wundern: steht nur „cdc is not on this system“ da, weil foto ging in’s irc an mitfummlern –

    gruß,
    Cpt’n Decruncher

  • kettwiesel

    hahahha wie wärsn damit ?

    die recoverie für das Teil ? Ist auch ein Update…

    http://ntp-gmbh.com/support/Firstview_PC706_LAN_FW_Update_Q-Book_Netto.zip

    1. Kopieren Sie den „script“ Ordner und die „uboot.bin“ Datei auf eine leere, formatierte
    SD-Speicherkarte.
    2. Stecken Sie die SD-Speicherkarte in das das Q-Book Mini-Netbook ein und schalten Sie es ein.
    3. Warten Sie bis der Updatevorgang beendet ist und folgende Meldung erscheint:
    „Please remove SD card“. Entfernen Sie die SD-Karte und starten Sie das Gerät neu.

    der Witz dabei ist ja wieder….

    wer hat so was alles „standardgemäs“ bei sich herumliegen ?!
    Und wer kommt überhaupt darauf !

    Nicht erschrecken das Update kommt in Chinesische Zeichen !
    Wird aber dann wieder deutsch !

    PS: ich habs erst auf einen USB stick geschoben und dann auf die SD Karte kopiert.

  • kettwiesel

    heiliger bimbam wie groß ist den die datei ?

    30 Mb hatter bis jetzt.

    ich hab nur DSL mit 356 K

  • admin

    @kettwiesel: Zu Deinem Kommentar #104 lies mal meinen unter #30 – da haben wir wieder diese NTP – new tech products GmbH. Nu wissen wir, wer den Vertrieb für unser Q-Book macht (den Verdacht hatte ich gestern schon, als ich die Specs vom Westfalia-Netbook gesehen habe). Jay tech ist also wohl raus aus der Nummer…

    Hast Du die Datei nun laden können? Kannst Du damit was anfangen und funktioniert bei Dir was? Datei ist um die 100 MB groß…

  • Borzel

    #cat /proc/cpuinfo

    Processor : ARM926EJ-S rev 5 (v5l)
    BogoMIPS : 174.48
    Features : swp half thumb fastmult edsp java
    CPU implementer : 0x41
    CPU architecture: 5TEJ
    CPU variant : 0x0
    CPU part : 0x926
    CPU revision : 5

    Hardware : WMT
    Revision : 0000
    Serial : 0000000000000000

    #lsusb

    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    #lspci

    00:02.0 Ethernet controller: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter (rev 84)
    00:04.0 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
    00:05.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)

    weitere Daten folgen

  • emma

    der download von # 104 beinhaltet eine GPL-violation. Wie es aussieht wird ueber u-boot gebootet.
    Nachricht an gpl-violations.org ist raus.

  • emma

    @Borzel: sehr nett!

    einfach fatpart.tgz und extpart.tgz genommen?
    (hab grade weder SD-card noch schnelles internet)

    wie siehts mit dem onboard NAND aus, kann man das sehen/mounten/beschreiben/von booten?

    ma

  • Max

    @ cdc:
    Hallo,
    vielen Dank für die Information.
    Das Gerät aufschrauben will ich nicht so gerne, wie du bereits schon gesagt hast, danach besteht keine Garantie mehr.
    Ich habe den Akku jetzt komplett aufgeladen. Das LED „aufladen“ leuchtet nicht mehr auf. Betätige ich die Taste „Einschalten“, leuchtet das LED, als ob der Rechner im Betrieb wäre. Allerdings bleibt der Bildschirm schwarz. Ich könnte mich in den Boden ärgern! Jetzt habe ich nicht einmal die Gelegenheit gehabt das Ding zu testen. Bin noch am überlegen es auszutauschen (falls überhaupt noch welche vorhanden sind) oder das Geld zurückzuverlangen.
    Nur ärgerlich ;-(

  • Borzel

    @emma

    keine Ahnung, hab ich noch nicht probiert… der größte knackpunkt ist entsprechenden swap anzuklemmen … habs mit externer Festplatte, usbstick und jetzt auf sd-Karte probiert festplatte war so gefühlt am schnellsten 🙂

    das mit dem NAND will ich erstmal lassen … vieleicht ist das CE noch zu was nütze 😉

  • Borzel

    @emma
    wer lesen kann … ja, ich hab die beiden tgz genommen und nach Anleitung ne 2 GB SD-Karte formatiert (100MB FAT16 / Rest ext2)

    den nand (mtdblock7) hab ich mir grade durch mountversuche zerschossen … da wird’s jetzt also doch swap …

    hab mal schnell
    #mkfs /dev/mtdblock7
    ausgeführt und df -h sagt mir: Size 291M

    bissel Benchmark:

    #hdparm -t /dev/mtdblock7
    4.62 MB/sec

    #hdparm -T /dev/mtdblock7
    37.86 MB/sec

    #hdparm -t /dev/mtdblock9
    6.55 MB/sec

    #hdparm -T /dev/mtdblock9
    37.78 MB/sec

    /dev/mtdblock7 bringt ecc fehlermeldungen 🙁

  • Wilhelmine

    Hallo Admin,
    herzlichen Dank für Deine ausführlichen Recherchen und Erklärungen.
    Ich habe noch eine große Bitte an Dich: Habe gerade den bis 25.01.2011 gültigen Media-Markt-Prospekt vor mir. Auf der Rückseite wird das Netbook von packard bell DOT SE 045GE zum Preis von 272,09 € angeboten. Kannst Du Dir die Daten mal ansehen? Anstelle des von Dir vorgeschlagenen „Intel Atom“ Prozessors N450 mit 1,6 GHz hat dieses Netbook den „Intel Atom“ Prozessor N550 (1,5 GHz, 1 MB L2 cache). Was ist hier der Unterschied?
    Sorry, daß ich so dumme Fragen stelle, aber ich bin schon etwas älter und ich wir arbeiten hier im Büro erst seit einigen Jahren mit Computern und dann ist auch alles bereits vom Netzwerk her eingestellt.
    Liebe Grüße von Ingrid

  • Solarpeter

    Hallo Admin, hallo zusammen,
    hab mir das Q-book besonders wg. email und Internet gekauft. Beides möchte ich schwerpunktmäßig in der Türkei nutzen. Auf der Seite 39 ff.der Bedienungsanleitung steht das aber mit dem o2 bzw. Tchibo Stick. Mir geht es wie „Wilhelmine“, die ihr Gerät deshalb zurückgebracht hat. Wer hat Erfahrungen, ob das Q-Book auch mit anderen Sticks läuft, ohne große Veränderungen vornehmen zu müssen. (Einschalten und muß gehen..) Danke und Gruß, Solarpeter

  • cdc

    @max
    gut, wenn das gerät startet, aber nichts anzeigt kann fallen mir ein paar ursachen ein:

    a) wenn du die kiste mal „bind booten lässt“ und einen sound hörst (wince start sound – glaub da war einer), dann wirds das sein:
    – displayfehler (display selbst, kabel display-connector oder connector selbst oder vga-chip)

    b) wenn a) nicht zutrifft, dann deutet das auf einen „halt on fault“ hin:
    – fehler im rom (bios-rom unsauber geflasht/herstellungsfehler)
    – platinenfehler (controllerverbindungen vga-cpu, prozessor-fehler)

    loader auf internen ssd würde ich ausschliessen, weil dann müsste wenigstens was kommen von „critical: unable to load image“.

    aufjeden fall umgehend zurückschaffen!!!

    gruß,
    Cpt’n Decruncher

  • kettwiesel

    @ Admin

    Ja deine Programme Laufen fast alle , hab 1000 Dank dafür, jetzt kann das Ding wenigstens ein bisschen was 😉

    Aber das ein „PC“ nicht Drucken kann, und keine Anderen USB teile installieren lässt so ein Scheiß ! echt. Das Wlan kann ich somit nicht verlängern mit einem USB Kabel und einen Externen Stik dazu.

    In die Garage oder in den Garten will ich mich nicht gerade hocken weil dort Schluss ist mit wlan.

    Oder hat einer von euch eine Idee wie man dem Teil das Beibringen könnte?

    LG kettwiesel

  • admin

    @Peter

    Also, das Problem mit den Surfasticks und Windows CE (und damit mit Surfsticks und dem Q-Book, 9901 etc.) ist schlicht die Treiberversorgung. Mir sind lediglich Treiber für folgende zwei Sticks vbekannt:
    Huawei e180
    Huawei e1550
    So, nun gilt es herauszufinden, welcher der von verschiedenen Providern angebotene Stick dem tatsächlich entspricht. Den musst Du Dir besorgen und dann auch sicherstelen, dass er mit der türlkischen SIM-Karte Deiner Wahl funktioniert. Das dürfte gar nicht so einfach sein, aber ein Ding der Unmöglichkerit ist es wohl auch nicht (google nach den entsprechenden Sticks und schau auch hier im Blog auf den Artikel zum 9901 –> Suche, –>“9901″ als Suchwort, da findest Du alles in Übersicht).
    Ich zitiere jetzt mal von der Jay tech – Seite (da ein Direktlinkt nicht funktioniert):
    „Schritt II
    Den UMTS Stick in den reinen Modemmodus schalten.

    Hierzu benötigen Sie einen Windows XP Rechner. Um in das Hyperterminal zu gelangen gehen Sie wie folgt vor.

    Start > Programme > Zubehör > Kommunikation > HyperTerminal

    Hier müssen Sie eine neue Verbindung herstellen, dies machen Sie folgendermaßen
    Neue Verbindung >beliebigen Namen eingeben> mit OK bestätigen > Rufnummer > 0 eingeben und Ihren HUAWEI Stick als Modem auswählen.

    Im nächsten Schritt brechen Sie die Verbindung ab und geben in das HyperTerminalfenster die Buchstaben ATZ ein und bestätigen die Eingabe mit enter, dies wird vom Hyperterminal mit OK bestätigt
    Nun geben Sie den Befehl at^u2diag=0 oder at^u2diag=256 ein
    Ihr Huawei Stick sollte sich jetzt im Modemmodus befinden
    Falls Sie Ihren Surfstick wieder mit einem normalen PC nutzen möchten, befolgen Sie die oben genannten Schritte geben aber den Befehl at^u2diag=255 ein

    Schritt III

    PIN Abfrage ausschalten
    Die PIN Abfrage für Ihre SIM Karte ausschalten. Hierzu legen Sie die SIM Karte in ein beliebiges Handy und schalten dort die PIN Abfrage aus. Da dies von Modell zu Modell unterschiedlich ist, können wir hierauf leider nicht genauer eingehen.

    Schritt IV

    Verbindungsdaten ins Netbook eingeben.
    DNS eingeben
    Start > Einstellungen > Netzwerk und DFÜ > rechte Maustaste 3 G Modem > Eigenschaften
    TC/IP Einstellungen > Namenserver
    Hier geben Sie unter dem Punkt DNS 193.189.244.225 ein und bestätigen mit OK
    DOMÄNE eingeben
    Start > Einstellungen > Netzwerk und DFÜ > linke Maustaste Doppelklick 3 G Modem
    Hier geben Sie unter dem Punkt DOMÄNE internet ein und drücken auf verbinden.

    Das ist das, was mich an diesen Mini-Netbooks so sakrisch ärgert – ein Normaluser gibt an dieser Stelle gerne mal auf, weil er keine Lust hat, im Hyperterminal rumzukratzen. Das ist exakt der Grund, warum ich z.B. Ingrid geraten habe, sich ein stinknormales Windows XP/7-Netbook zu kaufen. Das mit den Surfsticks ist in meinen Augen Quelle ständiger Ärgernisse.

  • admin

    @kettwiesel
    Nö, meines Wissens geht das nicht, aber wenn Dein Grundstück so groß ist, dass Du mit deinem WLAN nicht rumkommst, dann ist die Investition in einen WLAN-Repeater sicher ganz gut angelegtes Geld.

  • admin

    @Ingrid: Der Unterschied dürfte nicht die Welt ausmachen, der Prozessor, den Du beschreibst, ist zwar nominell langsamer aber dafür etwas neuer – dürfte auf die Praxis aber nur minimale auswirkungen haben…
    Wenn Du Dir das Netbook beim Mediamarkt kaufen willst, nimm doch Deinen Surfstick mit, lass Dir vom Verküfer zeigen, wie das alles geht, was Du brauchst…
    … und wenn Du damit klar kommst und es Dir gefällt, dan kauf es einfach 🙂

  • kettwiesel

    trick 17 zwecks externen Wlan….(USB Stick)

    Man nehme ein altes DSL Wlan Moden, (speedboard zB. Fitzbox ecpp)
    und stellt das Teil so ein das es das Wlan nur weiter gibt (Repeater)
    Kabel drann und das Ding hat Internet 😉

  • engelsfrau

    wir haben das dinge heute wieder zurück gebracht,weil meine tochter damit nicht ins vz rein kommt,er nicht mal spiele wie z.b gametwist oder so spielt.braucht ja stunden eh die seite geladen ist.also ich sage einfach es ist schrott,das ladekabel war so erhitzt das ich angst hatte das es durchbrennt.surfen internet ich sag zu langsammmmmm…..dauert zu lange.also hab mir mehr erhofft gehabt von den surfen im netz.
    wir haben unser geld zurück bekommen.kaufen lieber was anständiges und legen noch ein paar euro drauf.über das ding hab ich mich zu sehr geärgert.sehr enttäuscht!!!!
    lg

  • admin

    Na, das jemand mit dem Ding nicht ins VZ kommt, ist doch mal glatt ein Vorteil!! 😉

  • Borzel

    @kettwiesel

    wie schon öfters erwähnt, hat das Teil einen ARM-Prozessor.

    d.h.: Alles was unter Windows/Linux 32 und auch 64 läuft, geht da nicht. Punkt.

    Es läuft nur Software, die für die ARM-Architektur kompiliert wurde (quasi das Exe-Erstellen). Alles was für x86 oder x64 gedacht ist geht NICHT. Es ist kein Intel- oder AMD-kompatibler Prozessor, es ist ARM (http://de.wikipedia.org/wiki/ARM-Architektur)

    So, was nun läuft ist:
    – Unixe/Linuxe für ARM (Debian, Andriod, …)
    – Windows CE
    – ARM-Assembler (schreibt das jemand selber von euch?)

  • Borzel

    und was auch noch ist:

    er booted NUR von SD-Karte

  • emma

    so, hab nun auch endlich linux laufen, das debian via fatpart.tgz und extpart.tgz

    hab heute mal versucht android zu installieren, aber das display blieb schwarz. Das koennte aber auch ein HW-Fehler hier sein, auch unter debian, oder dem recovery passiert das bei Zeiten.

    momentan noch alles „live“ von SD-card, werd’s aber gleich mal installieren.

    @Borzel: Arm-assembly, BTDT, allerdings schon ein paar Jahre her =)

    Ich will da elinks/lynx, vim, gcc, perl und Artgenossen (nethack?:) drauf rumlaufen lassen.

  • Borzel

    links2 läuft sehr gut, es muss jedoch genug swap-speicher da sein, sonst beendet es sich selbst bei größeren Datenmengen (Bildern, …)

    Das Netzteil wird sehr heiß, wenn das Netbook läuft und gleichzeitig Akku lädt. Sieht man irgendwie, wenn der Akku voll ist? Geht dann die grüne LED aus?

    Also alles in allem bin ich recht zufrieden mit dem Gerät für den Preis. Ich kann mich spontan mit Leuten in der Wildnis treffen und Digitalkommunikation haben, sowohl auf Datenträger- als auch Internetbasis. Und wenn sogar KDE läuft (oder kriecht 🙂 ), dann isses ja ne feine Sache.

    @emma:
    Assembler hab ich noch net gemacht (außer bissel im Abi/Studium, schon ein paar Monate her 🙂 )

    wir könnten hier ja fast ein eigenes Forum aufmachen 😉
    bist du hier (http://devio.us/~nextvolume/via_arm/index.php) aktiv ?

  • Toni

    bei mir funkt es in der steckdose wenn ich den stecker vom netzteil reinstecke und es macht komische geräusche beim laden und es wird richtig Heiß deswegen benutze ich ein anderes Netzteil was von der Volt und mA zahl passt

    sobald der Akku voll ist geht die grüne LED aus

    zum internet also normale seiten lassen sich bei mir nicht öffnen da hängt sich das ganze system auf aber mobile seiten wie die vom Handy, laufen bei mir ohne probleme

    jezt muss ich nochmal fragen kann man die installation sperre umgehen würde mir gern Soft Maker office installieren oder habt ihr ein trick wie ich es auf nen Stick installieren kann vielen Dank

  • Snoopy601

    So Jungs und Mädels, ich habe auch auf die ganzen Unkenrufe nicht gehört und mir dieses Mini-Netbook geholt. Nach einigen Tests mit Internet über Wlan kann ich nur sagen: Hier übt man sich in ZEN-Buddhismus (Zuschauen-Entspannen-Nachdenken…). Am besten man nimmt sich da eine große Thermoskanne Kaffee und gaaanz viiiiiel Zeit. Eine Zeitschonende Recherche-Arbeit im Internet ist damit nicht möglich – schade.
    Übrigens bin ich mir nicht so ganz sicher, ob das Q-Book tatsächlich mit 533Mhz läuft. Wenn man den Core Player startet und unter Optionen guckt, zeigt das Programm einen Clock-Speed von ca 320Mhz. Eigenartig. Hier bräuchte man ein Tool, wie z.B. SisoftSandra, daß einem das Technische Innenleben zuverlässig etwas auflistet. Auf eine Verkaufspappschachtel kann man ja auch alles mögliche drauf drucken, doch ob es auch stimmt…?
    Bleibt also zum Vernünftigen Zweck für dieses Q-Book z.B. noch eine Office Anwendung, doch ich habe es nicht auf direktem Weg nicht zustande gebracht die Softmaker Office Suite darauf zu installieren (Hier sind die Kenner gefragt, weshalb man nachträglich keine Software auf dem Netbook installieren kann…vielleicht in der Registry rumschrauben…?). Es kommt immer die gleiche Fehlermeldung, daß die Software nicht installiert werden kann. Deshalb bin ich den Weg über eine PDA Pocket PC Installation gegangen und habe die Office Suite 2010 DEMO von Softmaker dort installiert und anschließend die Programmdateien auf daß Q-Book übertragen. Und es läuft. Damit hier einige Leute die Softmaker Office ausprobieren können habe ich es hier draufgepackt:http://www.file-upload.net/download-3103597/Softmaker-Office-2010-Demo.rar.html
    Als Rar-Archiv ca. 60 Mb für WinCE. Ich werde mich mit der Demo mal beschäftigen und mir eventuell die Vollversion kaufen. Softmaker hat ja manchmal so Gratis-Aktionen, aber ich glaube die betrifft nur die „normale“ Windows-Versionen – oder?
    Grüsse, Snoopy601.

  • admin

    Zumindest bei Softmaker (die haben ja einen halbwegs ordentlichen Support) kannst Du ja mal anfragen. Vielleicht gibt es ja verbilligt einn „Update“? Einfach versuchen – was schlimmeres als „läuft nicht“ oder „läuft, aber du musst für die neuste Version voll blechen“ werden sie Dir ja kaum sagen können…

  • toni

    warum wir nichts drauf spielen können könnte daran liegen das wir ein gast konto haben soweit ich das sehe

  • cdc

    @borzel
    selbige holzbein variante für boot von usb wäre z.b. hier zu finden: http://bento-linux.org/wiki/vt8505/wm8505/debian/live-boot-sd-usb

    bios -> loader von internen ssd -> chainloader von sd -> boot von usb

    genau genommen, macht der chainloader (eigendlich mehr ein reloader) nicht anderes, sofern ich das richtig analysiert hab, als das bootimage von chainloader (auf sd) im ram mit dem bootimage vom usb-gerät (zu erst gefundener) zu überschreiben und wieder in den entry-point zu springen. wie gesagt: holzbein lösung für jedermann.

    @kettelwiesel
    ich würde statt dsl eher auf tinycore (http://tinycorelinux.com/) setzen, das müsstest du dir allerdings auch erst für arm cross-compen. quellen findest du hier: http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/3.x/release/src/

    @admin
    lach, wenn facebook, lokalisten und die restlichen „stasi für jedermann“-netzwerke nicht funktionieren ist das sogar ein enormer vorteil; da hast du recht.

    gruß,
    Cpt’n Decruncher

  • cdc

    @kettelwiesel
    ach und mir fiel aber eben noch ein, du könntest dir auch:

    a) ein eigenes basteln, mit einer sandbox (wäre vorteilhaft, weil baut die toolchain selber). schau mal hier: http://t2-project.org/ (ist meiner meinung nach das beste. hab ich selber oft genutz um mal fix paar testumgebungen zu bauen)

    b) eigens linux basteln, von hand:
    – guter leitfaden für einsteiger: http://www.linuxfromscratch.org/
    http://users.cecs.anu.edu.au/~okeefe/p2b/power2bash/power2bash.html (mein favorit, nur leider immer noch zu zugemüllt)

    vorgehensweise ist aber in allen fällen die gleiche:
    – toolchain bauen (glibc, gcc, binutils [as, ld], bash [oder busybox: sh/ash/msh), und dann die „Nutztools“ [awk, grep, sed, make, …]
    – chrootetest du einfach in die neue toolchain
    – fs-struktur anlegen
    – dort erst glibc bauen
    – dann kernel bauen
    – ne shell (emfehle da busybox zu verwenden; bei bash brauchst du dann noch readline & ncurses + die anderen tools die in busybox schon drin sind)
    – … was du sonst noch so brauchst bauen – stripping nicht vergessen, spaart so im schnitt 10% an platz und ramverbrauch …

    – mit mknod oder dem alten slaxscript „mkdevs“ (glaub findest du im lfs)

    – dann noch fix init-script schreiben und als „init“ im fsroot (/) ablegen:
    aus minimalsitenschen gründen würde das reichen:

    #! /bin/sh
    mount / -o remount,rw
    mount -t tmpfs IstEgalWieDuDasNennst /dev/shm
    # falls du sysfs/procfs im kernel exportieren lässt
    mount -t sysfs IstEgalWieDuDasNennst /dev/sys
    mount -t procfs IstEgalWieDuDasNennst /dev/proc
    /bin/sh # <– damit haste ne shell, mit der du nix machen kannst, wie gesagt der absolute kern

    – dann einfach eine ramdisk draus machen

    – mkimage daraus ein image erstellen (mkimage findest du für x86 vorgebaut hier: http://bur.st/%7Eabrasive/wm8505_linux/1.0/fatpart.tgz )

    absoluter kern, damit überhaut ein linux startet sind folgende dateien:
    glibc/dietlibc/libc/oder sonstige (ldlinux.so, …), dann noch ne shell (gelinkt nach /bin/sh oder nach angabe in /etc/passwd), /etc/init, /etc/passwd, /etc/fstab, /dev/null, /dev/ram – den kernel + module und die ramdisk hast du ja schon – so mehr auch nicht. wenn du dann alles bis auf den punkt: „was du sonst noch so brauchst bauen“ sollte das ganze linux nicht größer als 1mb (je nach deiner kernel-config, und ob du beim compen brav „–disable-nls“ und sowas angegeben hast) sein.

    c) (und ich denke, die variante ist dir lieber) ein linux was schon auf arm gebaut ist: neben debian fällt mir noch das ein http://www.linaro.org/downloads/ – musst halt mal bissel googlen, ich bau mir das linux in der regel immer selber zurecht, auf einen zeck zugeschnitten.

    gruß
    Cpt’n Decruncher

  • cdc

    @Snoopy601
    unter wince, läuft die kiste etwas auch mit 533mhz (bei risc-porzessoren ist das nur so eine zahl), den einzelnen prozessen werden aller dings vom wince 6 (- ja angeblich „realtime“, wenn ich das schon höre überkommt mich der lachkrampf -) jedem eine prozess pauschaule rechenlast zugeteilt. ob das die 320mhz sind kann ich dir nicht genau sagen, jedenfalls weniger als 533 (hätte auf ca. 400 geschätz, jedenfalls nach der berechnung von pi, aber da rührt ja auch der ram bissel mit rum).
    snoopy, ob das wince da flash hat kann ich nicht sagen, aber ich denke – wenn – man wird das deaktivieren können. 90% der ganzen werbung auf seiten im netz ist flash, und das macht selbst aus einem intel p-ii einen 486! eventuell kann man das deaktivieren, da müssten dir die anderen mal helfen, die wince nicht sofort gekickt haben (wie beabsichtigt). zurückdumpen/wiederherstellen mag ich es auch nicht, denn dann ist bissel arbeit flöten. zum thema recherche… gut, wenn man bilder deaktiviert und co. spart das ram, bandbreite, und ab und zu auch nerven. im explorer (k.a. bin kein windowser) gibts glaub ich auch ne variante emca-script (aka. javascript) auszuschalten, das verbraucht auch nur sinnlos resourcen für teilweise bekloppte popups.

    gruß,
    Cpt’n Decruncher

  • toni

    sorry ich habe da eine frage ich habe mir die datein fatpart.tgz und extpart.tgz
    runtergeladen wie kann ich jetzt meine SD-Karte unter windows XP formatieren oder gibt es eine deutsche schritt für schrit anleitung weil ich das mal testen will danke schonmal

  • cdc

    hallo,
    @borzel
    ich code ausschließlich assembler (meisst arm, weniger mips, ppc, noch weniger x86/64) seit nun mehr über 35jahren (damals allerdings auch andere architekturen – ab und an geb ich mir auch noch mal die blöse auf paar 64 teile oder zx80 oder vecs-krams zu coden), allerding ab und an rutschten mir auch mal paar c-zeilen von der hand. für fixe, schnelle lösung, wo es egal ist, ob das assembly dann 100%-optimiert oder 100%-minimiert ist, ist c schon brauch bar. c/c++/d# ist halt das moderne cobol (lach). warum fragst du?
    @toni
    gehe ich recht in der annahme das du von dem hier sprichst: http://bento-linux.org/wiki/vt8505/wm8505/debian? deutsche an leitung wüsste ich jetzt nicht.

    ich mach mal die einfach, windows-freundliche variante, denn es dauert mir schlicht zu lange erst so befehle erklären zu müssen wie fdisk, mkfs, un-/mount, tar, cd, ggf. sudo – mehr wird man nicht brauchen. nun die win-variante:

    – gute, kostenloses partitionierungs prog für win wüsste ich nicht. da müsste dir mal ein windowser unter die arme greifen; mir fällt auf anhieb nur die gparted-livecd (http://gparted.sourceforge.net/) ein – das ist jedenfalls so die einfachste variante für nicht-linuxer, weil fontend und viele bunte knöpfchen und menüs….

    – auf der sd-karte die partition löschen

    – dann 1 partitionen anlegen (primär 1, fat16, größe 64mb – auch wenn da 32m steht, würde lieber auf nummer sicher gehen)

    – dann 2. partition anlegen (primär 2, ext2, restliche größe)

    – änderung übernehmen

    – windows booten

    – einen realtiv guten ifs-treiber für ext2/3 installieren: http://fs-driver.org/download/Ext2IFS_1_11a.exe

    – 7z kann .tar.gz/.tgz-archive lesen/entpacken

    – fatpart.tgz auf die fat-partition und extpart.tgz auf die ext2-partition entpacken

    – sd-karte noch syncronisieren/aushängen (glaub das schimmpft sich „laufwerk entfernen“? unten im systray)

    gruß,
    Cpt’n Decruncher

  • emma

    Bin mir nicht ganz sicher, aber ich denke, ich hab mir durch den Versuch einer Android-Installation den Bootloader angeknackst.
    =(
    Das recovery via Firstview_PC706_LAN_FW_Update_Q-Book_Netto.zip sieht gut aus, man sieht das chinesische WinCE sich fertiginstallieren. Danach aber bootet es nicht.
    Generell hab ich den Eindruck es bootet _nur_ mehr von SD-card. vom internen NAND bekomme ich das nicht hin.
    Kann mir jmd irgendwie ein backup zukommen lassen, von
    ffff0000 +10000
    und
    fff80000 +50000

    und evtl. ein printenv

    Wie gesagt, von SD-card kann ich alles sauber booten, aber nicht ohne, das Display bleibt schwarz. Und es bootet auch nicht blind, da der Startsound von WinCE nicht kommt.

    Hat jmd schon mal erfolgreich eine Serielle angebaut?

  • toni

    mir bitte auch habe mir ist das gleiche mit androide passiert

  • Snoopy601

    @Admin #130
    Ich Habe mir mal die Softmaker Office 2008 am Desktop Rechner installiert, da gab es nämlich noch einen Freischalt-Schlüssel im Netz. Bei der Registrierung mußte man seine Email-Adresse angeben. Also früher oder später wird man dann irgendwann eh von Softmaker „eingeladen“ auf eine aktuelle Programmversion upzudaten und ich kann dann ja versuchen ein Cross-Upgrade zum ermäßigten Preis zu bekommen. Was Office auf Windows CE Betriebssystem anbetrifft hat Softmaker ja sowas wie ein Alleinstellungsmerkmal und ich bin durchaus mal bereit etwas Geld für Software auszugeben, wenn die Qualität, Service usw. stimmt. Immerhin steckt in solchen Programmen jede Menge Manpower drin und umsonst ist ja nicht mal der Tod.

    @Toni #131
    Was heißt hier Gastkonto? – Was meinst du, wie ich das Q-Book Nächtens angeschrien habe (Alle Lichter in der Nachbarschaft gingen an…): „So lange du deinen Akku über MEINE Steckdose auflädst, bin ICH hier der Administrator…!!“ – Nun ja, genutzt hat es aber auch nichts.

    @cdc #133
    Ja, dann wäre das mal geklärt mit den Mhz. Hätte ich mir ja gleich denken können, daß es ein Multitasking System ist und die Programme je nach dem entsprechend Power zugeteilt bekommen.
    Das mit dem Internet ist halt von der Geschwindigkeit eine Gewöhnungsangelegenheit. Immer noch besser, als mit dem PDA Surfen.
    Grüsse, Snoopy601.

  • emma

    cool, hab die Serielle gefunden. Ist hier nicht beschriftet, aber doch einfach zu finden. Unter der Tastatur, ca. unter den Buchstaben S D ist ein Viereck mit 4 pins markiert, das sind

    Vcc(?) Rx Tx GND

    Achtung, das ist keine normale Serielle, denn die Pegel sind nur 3.3V !

    Hier sieht man auch, dass ich mehrere Bootversuche brauche, bis W-Load auch u-boot startet. Wie gesagt, ich will/werde damit debuggen, warum ich mit dem Android-Installationsversuch mir die Moeglichkeit geschossen habe, von NAND zu booten.

    ———————————-snip———————————-
    WonderMedia Technologies, Inc.
    W-Load Version : 0.17.00.00

    WonderMedia Technologies, Inc.
    W-Load Version : 0.17.00.00

    WonderMedia Technologies, Inc.
    W-Load Version : 0.17.00.00

    WonderMedia Technologies, Inc.
    W-Load Version : 0.17.00.00
    ethaddr…………found

    U-Boot 1.1.4 (Feb 25 2010 – 14:14:20)
    WonderMedia Technologies, Inc.
    WMT U-Boot Version : 0.12.01.00.13
    U-Boot code: 03F80000 -> 03FB820C BSS: -> 04006624
    RAM Configuration:
    Bank #0: 00000000 128 MB
    boot from spi flash.
    flash:
    Bank1: FF800000 — FFFFFFFF
    Bank2: FF000000 — FF7FFFFF
    Flash: 16 MB
    In: serial
    Out: serial
    Err: serial
    ### main_loop entered: bootdelay=5

    bootcmd=“nand readblob 3C00000 3E00000;logo show“
    maddr = 0x3c00000, naddr = 0x3e00000

    Read header
    CE0: NAND FLASH ID: 0xECD59429
    Err : Can not find any nand flash
    Init Flash Failed rc=-1
    Header is 0x95b495b4 0x95b495b4
    error: magicNum = 0x95b495b4, it should be 0x80101000

    show logo …..
    LCD param (setting): 1,30000,8,800,480,48,40,40,3,29,13,d8110508|10,d8110504|10,d8110500|10
    PWM param (setting): 0,25,100,90,98,58,8,0,27
    LCD FrameBuffer = 0x07600000, BMP Address = 0x03C00000
    Error : Not BMP Format
    Execute register operation:
    reg op: 0xD8110064 | 0xC
    reg op: 0xD811008C | 0xC
    reg op: 0xD81100B4 & 0xFFFFFFFB
    reg op: 0xD81100B4 | 0x8
    reg op: 0xD8130054 | 0x1
    ### main_loop: bootcmd=“nand readblob 100000 0;go 100000″
    Hit any key to stop autoboot: 0
    WMT # cool, serial up and running
    Unknown command ‚cool,‘ – try ‚help‘
    WMT #
    ———————————-snip———————————-

  • Snoopy601

    An alle Bastler!
    Schön, daß ihr eure Experimentierfreude mit dem Q-Book habt, aber ich sehe es schon kommen: Bei Ebay werden in den nächsten Wochen wieder neue Chargen mit Q-Books auftauchen mit so ähnlichen Angebotstexten, wie z.B.: „…Netbook startet nicht mehr, keine Ahnung warum, vielleicht nur ein Wackelkontakt. Für Bastler sicher kein Problem…“; oder in Abwandlung in dem man eine Sachkompetente dritte Person zitiert: „…ein Freund sagte mir, es liegt ein Wackler vor, ich selbst kenne mich aber mit dem Netbook nicht so aus…“
    Ich wollte das nur erwähnen, damit Euer Taschengeld von den Eltern oder Ehegatten fürs nächste Monat nicht gesperrt wird.
    Grüsse, Snoopy601.

  • toni

    @cdc vielen dank werde mich morgen mal dran machen

  • cdc

    @Snoopy601:
    also ich würde mir dann doch glatt noch einen hohlen, nur leider bis jetzt nichts auf ebay gefunden (vergünstigt). noch ne zweite rechenschleuder wär nicht schlecht.

    gruß,
    Cpt’n Decruncher

  • Snoopy601

    @Cpt´n Decruncher
    ich hatte bei ebay mal ein Angebot mit 6 defekten JayTech Netbooks gesehen und auf meine Beobachtungsliste gesetzt, doch das Endgebot erreichte eigenartigerweise doch einen Eurowert von über 60,-. Da war für mich doch die Schmerzgrenze erreicht.
    Übrigens habe ich bei meinem Netbook eine defekte Audiobuchse festgestellt (nur ein Audiokanal funktioniert). Wäre ja ein Fall für Reklamation, aber auch wieder ein vernünftiger Grund mal das Ding selber aufzuschrauben.
    Grüße, Snoopy601.

  • Dirk

    @ emma # 137

    Hallo,

    habe das gleiche Problem: versucht Android zu installieren mit der Folge eines schwarzen Bildschrims. Anschließend versucht, WinCE mit den Recovery-Files wieder aufzuspielen mit dem Ergebnis eines schwarzen Bildschirms nach der Installation…das Q-Book bootet einfach nicht, obwohl das „chinesische WinCE“ ordentlich installiert wurde. Gibt es zwischenzeitlich eine Lösung, das Q-Book wieder zum Booten vom internen Flash-Speicher zu bewegen?

    Grüße

    Dirk

  • Lars

    Das Problem hatte ich auch. Android legt mehrere Partitionen auf dem internen flash an. darunter ist nur eine kleine partition eine fat. wenn mann dan versucht wieder das win ce zu installen reich der speicher dort nicht und er bricht vorzeitig ab. Ich habe dann ein live Debian aud die SD karte gepackt, davon gebootet und dann unter Linux den internen Flashspeicher gelöscht und eine 2 gig fat Partition angelegt. Danach einfach die Firmware von der JayTech seite installiert und alles ging wieder 🙂

    Gruß

  • Dirk

    @ Lars #146

    Hallo,

    vielen Dank für die Erklärung!

    Habe heute vormittag mein Q-Book wieder hinbekommen, allerdings mehr durch Kommissar Zufall! Habe im „Nachbar-Blog“ („Jay-Book 9901“) den Hinweis auf Android 2.1 gefunden. Hatte das -mehr aus Verzweiflung- installiert und siehe da, das Q-Book bootete wieder vom internen NAND-Speicher!
    Da mir aber die Version aufgrund einiger Bugs nicht gefiel, habe ich es einfach noch mal mit dem WinCE-Firmware-Update für das Q-Book von N.T.P. probiert. Und auch damit bootete es wieder!
    Und durch die Partition*EN* wird mir jetzt einiges klar; hatte die letzten Tage immer wieder mit einer englischen WinCE-Version (www.digitalgadgets.com/mini-netbook.php) probiert, die System Partition platt zu machen, aber leider ohne Erfolg. Kein Wunder, wenn es davon auf einmal mehrere gab aber nur eine angezeigt wurde unter WinCE…
    Aber jetzt weiß auch ich, wie es geht!!! 😉

    Grüße

    Dirk

  • Pogodancer

    @ Lars #146

    Hi Lars, habe als Linux-Laie nun unter höchster Anstrengung die Live-Debian-Linux-Version von der SD-Karte zum Laufen gebracht. Konnte aber keine Anwendung finden, die mir den internen Flash des Netbooks anzeigt und ihn ändern läßt. Könntest Du mir bitte erklären, wie ich von der Live-Debian diesen Internen Speicher ändern kann. Besten Dank im voraus.

    Manfred.

  • nico0885

    Hallo,
    kann mir bitte jemand helfen ich habe ein Mini notebook von Q-Media (http://www.q-media.eu/functions/list.asp?Lid=83&pnav=;2;102😉

    Das Gerät fährt ganz normal hoch aber dann haben ich nur einen weißen bildschirm, kann den maus-zeiger aber noch sehen und auch bewegen…

    Bitte um hilfe ( kein Rückgabe recht mehr 🙁 )

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.